Degraded Service in Grid Monitoring & Data Processing

Incident Report for Safety io Monitoring

Resolved

This incident has now been resolved.
Posted Feb 04, 2026 - 20:06 CET

Identified

We have identified the issue and are now working on a resolution.
Posted Feb 03, 2026 - 22:33 CET

Investigating

We are currently investigating an issue with our data processing and latency in API requests.
Posted Feb 03, 2026 - 20:54 CET
This incident affected: Grid (Website, Data Processing).