Degraded service of Grid Monitor

Incident Report for Safety io Monitoring

Resolved

The issue has now been resolved and operations have returned to normal.
Posted May 26, 2026 - 15:29 CEST

Identified

There currently is a desynchronization of assignments between Grid Monitor and the rest of the application.
Depending on user's permissions this can lead to workers being visible in Grid Monitor and mobile push notifications not being received by the App.
Posted May 26, 2026 - 14:40 CEST
This incident affected: Grid (Website).