Global service disruption

Incident Report for Safety io Monitoring

Resolved

All services are operational.
Posted Oct 20, 2025 - 17:12 CEST

Update

We are continuing to investigate this issue.
Posted Oct 20, 2025 - 12:44 CEST

Update

We assume full service restoration by now, with no data loss or other direct customer impact.
Posted Oct 20, 2025 - 12:36 CEST

Update

All connected MSA products(including io4 and other connected products) are showing an offline status as of now.
Posted Oct 20, 2025 - 11:32 CEST

Update

We're currently experiencing a service disruption for all of our products due to issues with our infrastructure provider. Our teams are actively investigating the root cause and working to resolve the issue. We’ll share updates as soon as more information becomes available.
Posted Oct 20, 2025 - 11:05 CEST

Update

We are continuing to investigate the issue.
Posted Oct 20, 2025 - 10:30 CEST

Investigating

We're currently experiencing a service disruption affecting the Industrial Grid due to issues with our infrastructure provider. Our team is actively investigating the root cause and working to resolve the issue. We’ll share updates as soon as more information becomes available.
Posted Oct 20, 2025 - 10:12 CEST
This incident affected: Grid (Website, Mail reporting system, Data Processing), FireGrid (Website, Inventory website, Telemetry Processor), and Platform services (Login system).